What is CVE-2024-58351?
Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.
The record classifies CVE-2024-58351 under weakness class CWE-94. Its CVSS v3 base vector states that the flaw is reachable remotely over the network, needs no prior authentication, needs no user interaction, and has high impact on confidentiality, integrity, availability. 1 affected-product entry is recorded, across 1 vendor, listed below. The identifier was first published 139 days ago.
Severity and exploitation probability
- CVSS v3.1 base score
- 9.8 — CRITICAL
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS v4.0 base score
- 9.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - EPSS (FIRST)
- 0.6% probability of exploitation in the next 30 days, higher than 51.8% of all scored CVEs
- CISA KEV
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Threadlinqs priority
- 7/10 — a Threadlinqs composite of the CVSS base score, the EPSS percentile and public exploit availability
- Published
- 2026-06-20, last modified 2026-06-22
Is CVE-2024-58351 being exploited?
It currently carries a trending score of 18 in the Threadlinqs vulnerability feed.
Affected products and versions
- Flowise: Flowise
Affected software packages:
npm:flowise— patched in 2.1.4
How to fix CVE-2024-58351
Fixed versions are recorded for 1 package: npm:flowise 2.1.4. Vendor advisory: https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5cph-wvm9-45gj. Apply the vendor fix referenced above to every affected product listed in this record, then confirm the running version against the vendor advisory.
Threat activity tracking CVE-2024-58351
1 tracked threat in the Threadlinqs corpus references CVE-2024-58351, either in the campaign’s CVE list or as an indicator on the campaign record.
Sources
Enriched from CVE.org, NVD, FIRST EPSS, GitHub Security Advisories. Last verified by Threadlinqs on . This product uses the NVD API but is not endorsed or certified by the NVD.