Threadlinqs IntelligenceStart free

VulnerabilityCVE-2025-29927Published 2025-03-21

CVE-2025-29927 — vercel next.js

criticalPublic exploit11 PoC reposNuclei template

As of 2025-04-08, CVE-2025-29927 is a CRITICAL-severity vulnerability in vercel next.js, CVSS v3.1 9.1, EPSS 99.2% (99.9th percentile). Threadlinqs Intelligence links 2 tracked threat campaigns to CVE-2025-29927, most recently “PCPJack Worm — Cloud Credential Theft Framework Evicting TeamPCP Infections (CVE-2025-29927, CVE-2025-55182, CVE-2026-1357, CVE-2025-9501, CVE-2025-48703)”.

CVSS v3.1
9.1/10Critical
EPSS
99.2%Higher than 99.9% of scored CVEs
CISA KEV
NoNot in the KEV catalog
Tracked threats
2Campaigns referencing it
Priority
10/10Threadlinqs triage score
Published
Updated 2025-04-08
CVSS v3.1 9.1 (CRITICAL) · EPSS 99.2% (higher than 99.9% of all scored CVEs) · Priority 10/10 · Published 2025-03-21

Last updated:

What is CVE-2025-29927?

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

The record classifies CVE-2025-29927 under weakness class CWE-285. Its CVSS v3 base vector states that the flaw is reachable remotely over the network, needs no prior authentication, needs no user interaction, and has high impact on confidentiality, integrity. 1 affected-product entry is recorded, across 1 vendor, listed below. The identifier was first published 587 days ago.

Severity and exploitation probability

CVSS v3.1 base score
9.1 — CRITICAL
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS (FIRST)
99.2% probability of exploitation in the next 30 days, higher than 99.9% of all scored CVEs
CISA KEV
Not listed in the CISA Known Exploited Vulnerabilities catalog
Threadlinqs priority
10/10 — a Threadlinqs composite of the CVSS base score, the EPSS percentile and public exploit availability
Published
2025-03-21, last modified 2025-04-08

Is CVE-2025-29927 being exploited?

Weaponised exploit code for CVE-2025-29927 is publicly available. 11 public proof-of-concept repositories are tracked for this identifier. A ProjectDiscovery Nuclei detection template exists (http/cves/2025/CVE-2025-29927.yaml). It currently carries a trending score of 40 in the Threadlinqs vulnerability feed.

Affected products and versions

How to fix CVE-2025-29927

No vendor patch reference has been recorded for CVE-2025-29927 in the tracked sources. Follow the references below for a fix, and treat the products listed above as exposed until the vendor states otherwise.

Threat activity tracking CVE-2025-29927

2 tracked threats in the Threadlinqs corpus reference CVE-2025-29927, either in the campaign’s CVE list or as an indicator on the campaign record.

Sources

Enriched from CVE.org, FIRST EPSS, public proof-of-concept repositories, ProjectDiscovery Nuclei. Last verified by Threadlinqs on .

Vendor advisory and patch

Other references