What is CVE-2025-43504?
A buffer overflow was addressed with improved bounds checking. This issue is fixed in Xcode 26.1. A user in a privileged network position may be able to cause a denial-of-service.
The record classifies CVE-2025-43504 under weakness class CWE-119. Its CVSS v3 base vector states that the flaw is reachable remotely over the network, needs high-privilege credentials, needs no user interaction, and has high impact on availability. 1 affected-product entry is recorded, across 1 vendor, listed below. The identifier was first published 366 days ago.
Severity and exploitation probability
- CVSS v3.1 base score
- 4.9 — MEDIUM
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H - EPSS (FIRST)
- 0.3% probability of exploitation in the next 30 days, higher than 31.3% of all scored CVEs
- CISA KEV
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Threadlinqs priority
- 5.7/10 — a Threadlinqs composite of the CVSS base score, the EPSS percentile and public exploit availability
- Published
- 2025-11-04, last modified 2026-04-02
Is CVE-2025-43504 being exploited?
Weaponised exploit code for CVE-2025-43504 is publicly available. 1 public proof-of-concept repository is tracked for this identifier. It currently carries a trending score of 21 in the Threadlinqs vulnerability feed.
- calysteon/CVE-2025-43504 (github)
Affected products and versions
- Apple: Xcode
How to fix CVE-2025-43504
Vendor advisory: https://support.apple.com/en-us/125641. Apply the vendor fix referenced above to every affected product listed in this record, then confirm the running version against the vendor advisory.
Threat activity tracking CVE-2025-43504
1 tracked threat in the Threadlinqs corpus references CVE-2025-43504, either in the campaign’s CVE list or as an indicator on the campaign record.
Sources
Enriched from CVE.org, NVD, FIRST EPSS, public proof-of-concept repositories. Last verified by Threadlinqs on . This product uses the NVD API but is not endorsed or certified by the NVD.