What is CVE-2025-6264?
Velociraptor allows collection of VQL queries packaged into Artifacts from endpoints. These artifacts can be used to do anything and usually run with elevated permissions. To limit access to some dangerous artifact, Velociraptor allows for those to require high permissions like EXECVE to launch. The Admin.Client.UpdateClientConfig is an artifact used to update the client's configuration. This artifact did not enforce an additional required permission, allowing users with COLLECT_CLIENT permissions (normally given by the "Investigator" role) to collect it from endpoints and update the configuration. This can lead to arbitrary command execution and endpoint takeover. To successfully exploit this vulnerability the user must already have access to collect artifacts from the endpoint (i.e. have the COLLECT_CLIENT given typically by the "Investigator' role).
The record classifies CVE-2025-6264 under weakness class CWE-276. Its CVSS v3 base vector states that the flaw is reachable remotely over the network, needs high-privilege credentials, needs no user interaction. 1 affected-product entry is recorded, across 1 vendor, listed below. The identifier was first published 503 days ago.
Severity and exploitation probability
- CVSS v3.1 base score
- 5.5 — MEDIUM
CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L - EPSS (FIRST)
- 1.0% probability of exploitation in the next 30 days, higher than 63.8% of all scored CVEs
- CISA KEV
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Threadlinqs priority
- 7.3/10 — a Threadlinqs composite of the CVSS base score, the EPSS percentile and public exploit availability
- Published
- 2025-06-20, last modified 2025-11-28
Is CVE-2025-6264 being exploited?
Weaponised exploit code for CVE-2025-6264 is publicly available. 2 public proof-of-concept repositories are tracked for this identifier. It currently carries a trending score of 29 in the Threadlinqs vulnerability feed.
- Mauzy0x00/velociraptor_CVE-2025-6264_PoC (github)
- trickest/cve (trickest)
Affected products and versions
- Rapid7: Velociraptor
Affected software packages:
go:www.velocidex.com/golang/velociraptor— patched in 0.74.3
How to fix CVE-2025-6264
Fixed versions are recorded for 1 package: go:www.velocidex.com/golang/velociraptor 0.74.3. Vendor advisory: https://docs.velociraptor.app/announcements/advisories/cve-2025-6264/. Apply the vendor fix referenced above to every affected product listed in this record, then confirm the running version against the vendor advisory.
Threat activity tracking CVE-2025-6264
1 tracked threat in the Threadlinqs corpus references CVE-2025-6264, either in the campaign’s CVE list or as an indicator on the campaign record.
Sources
Enriched from CVE.org, NVD, FIRST EPSS, GitHub Security Advisories, public proof-of-concept repositories. Last verified by Threadlinqs on . This product uses the NVD API but is not endorsed or certified by the NVD.