Threadlinqs IntelligenceStart free

VulnerabilityCVE-2025-69263Published 2026-01-07

CVE-2025-69263 — Pnpm

highPublic exploit1 PoC repo

As of 2026-09-14, CVE-2025-69263 is a HIGH-severity vulnerability in Pnpm, CVSS v3.1 7.5, EPSS 0.4% (39.1th percentile). Threadlinqs Intelligence links 1 tracked threat campaign to CVE-2025-69263, most recently “Supply Chain Attacks on Crypto Ecosystem via Developer Toolchain Compromise”.

CVSS v3.1
7.5/10High
EPSS
0.4%Higher than 39.1% of scored CVEs
CISA KEV
NoNot in the KEV catalog
Tracked threats
1Campaigns referencing it
Priority
7.3/10Threadlinqs triage score
Published
Updated 2026-09-14
CVSS v3.1 7.5 (HIGH) · EPSS 0.4% (higher than 39.1% of all scored CVEs) · Priority 7.3/10 · Published 2026-01-07

Last updated:

What is CVE-2025-69263?

pnpm is a package manager. Versions 10.26.2 and below store HTTP tarball dependencies (and git-hosted tarballs) in the lockfile without integrity hashes. This allows the remote server to serve different content on each install, even when a lockfile is committed. An attacker who publishes a package with an HTTP tarball dependency can serve different code to different users or CI/CD environments. The attack requires the victim to install a package that has an HTTP/git tarball in its dependency tree. The victim's lockfile provides no protection. This issue is fixed in version 10.26.0.

The record classifies CVE-2025-69263 under weakness class CWE-494. Its CVSS v3 base vector states that the flaw is reachable remotely over the network, needs no prior authentication, needs a user to take an action first, and has high impact on confidentiality, integrity, availability. 1 affected-product entry is recorded, across 1 vendor, listed below. The identifier was first published 297 days ago.

Severity and exploitation probability

CVSS v3.1 base score
7.5 — HIGH
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS (FIRST)
0.4% probability of exploitation in the next 30 days, higher than 39.1% of all scored CVEs
CISA KEV
Not listed in the CISA Known Exploited Vulnerabilities catalog
Threadlinqs priority
7.3/10 — a Threadlinqs composite of the CVSS base score, the EPSS percentile and public exploit availability
Published
2026-01-07, last modified 2026-09-14

Is CVE-2025-69263 being exploited?

Weaponised exploit code for CVE-2025-69263 is publicly available. 1 public proof-of-concept repository is tracked for this identifier. It currently carries a trending score of 23 in the Threadlinqs vulnerability feed.

Affected products and versions

  • Pnpm: Pnpm

Affected software packages:

  • npm:pnpm — patched in 10.26.0

How to fix CVE-2025-69263

The record marks a vendor fix as available for CVE-2025-69263. Fixed versions are recorded for 1 package: npm:pnpm 10.26.0. Vendor advisory: https://github.com/pnpm/pnpm/commit/0958027f88a99ccefe7e9676cdebba393dfbdc85. Apply the vendor fix referenced above to every affected product listed in this record, then confirm the running version against the vendor advisory.

Threat activity tracking CVE-2025-69263

1 tracked threat in the Threadlinqs corpus references CVE-2025-69263, either in the campaign’s CVE list or as an indicator on the campaign record.

Sources

Enriched from CVE.org, FIRST EPSS, GitHub Security Advisories, public proof-of-concept repositories. Last verified by Threadlinqs on .

Vendor advisory and patch

Other references