Threadlinqs IntelligenceStart free

VulnerabilityCVE-2026-23918Published 2026-05-04

CVE-2026-23918 — Apache HTTP Server

highPublic exploit11 PoC repos

As of 2026-07-15, CVE-2026-23918 is a HIGH-severity vulnerability in Apache HTTP Server, CVSS v3.1 8.8, EPSS 49.7% (98.8th percentile). Threadlinqs Intelligence links 1 tracked threat campaign to CVE-2026-23918, most recently “CVE-2026-23918 — Apache HTTP Server mod_http2 Double Free Enabling Unauthenticated DoS and Possible RCE”.

CVSS v3.1
8.8/10High
EPSS
49.7%Higher than 98.8% of scored CVEs
CISA KEV
NoNot in the KEV catalog
Tracked threats
1Campaigns referencing it
Priority
10/10Threadlinqs triage score
Published
Updated 2026-07-15
CVSS v3.1 8.8 (HIGH) · EPSS 49.7% (higher than 98.8% of all scored CVEs) · Priority 10/10 · Published 2026-05-04

Last updated:

What is CVE-2026-23918?

Double Free and possible RCE vulnerability in Apache HTTP Server with the HTTP/2 protocol. This issue affects Apache HTTP Server: 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

The record classifies CVE-2026-23918 under weakness class CWE-415. Its CVSS v3 base vector states that the flaw is reachable remotely over the network, needs low-privilege credentials, needs no user interaction, and has high impact on confidentiality, integrity, availability. 1 affected-product entry is recorded, across 1 vendor, listed below. The identifier was first published 176 days ago.

Severity and exploitation probability

CVSS v3.1 base score
8.8 — HIGH
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS (FIRST)
49.7% probability of exploitation in the next 30 days, higher than 98.8% of all scored CVEs
CISA KEV
Not listed in the CISA Known Exploited Vulnerabilities catalog
Threadlinqs priority
10/10 — a Threadlinqs composite of the CVSS base score, the EPSS percentile and public exploit availability
Published
2026-05-04, last modified 2026-07-15

Is CVE-2026-23918 being exploited?

Weaponised exploit code for CVE-2026-23918 is publicly available. 11 public proof-of-concept repositories are tracked for this identifier. It currently carries a trending score of 38 in the Threadlinqs vulnerability feed.

Affected products and versions

How to fix CVE-2026-23918

Vendor advisory: https://httpd.apache.org/security/vulnerabilities_24.html. Apply the vendor fix referenced above to every affected product listed in this record, then confirm the running version against the vendor advisory.

Threat activity tracking CVE-2026-23918

1 tracked threat in the Threadlinqs corpus references CVE-2026-23918, either in the campaign’s CVE list or as an indicator on the campaign record.

Sources

Enriched from CVE.org, NVD, FIRST EPSS, public proof-of-concept repositories. Last verified by Threadlinqs on . This product uses the NVD API but is not endorsed or certified by the NVD.

Vendor advisory and patch