What is CVE-2026-41293?
Improper Input Validation vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 10.0.0-M1 through 10.0.27. Older, end of support versions may also be affected. Users are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.
The record classifies CVE-2026-41293 under weakness class CWE-20. Its CVSS v3 base vector states that the flaw is reachable remotely over the network, needs no prior authentication, needs no user interaction, and has high impact on confidentiality, integrity, availability. 1 affected-product entry is recorded, across 1 vendor, listed below. The identifier was first published 169 days ago.
Severity and exploitation probability
- CVSS v3.1 base score
- 9.8 — CRITICAL
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - EPSS (FIRST)
- 1.6% probability of exploitation in the next 30 days, higher than 76.2% of all scored CVEs
- CISA KEV
- Not listed in the CISA Known Exploited Vulnerabilities catalog
- Threadlinqs priority
- 10/10 — a Threadlinqs composite of the CVSS base score, the EPSS percentile and public exploit availability
- Published
- 2026-05-12, last modified 2026-09-17
Is CVE-2026-41293 being exploited?
Weaponised exploit code for CVE-2026-41293 is publicly available. 1 public proof-of-concept repository is tracked for this identifier. It currently carries a trending score of 32 in the Threadlinqs vulnerability feed.
- xiaoqiMikko/tomcat-check (github)
Affected products and versions
- Apache Software Foundation: Apache Tomcat
Affected software packages:
maven:org.apache.tomcat.embed:tomcat-embed-core— patched in 10.1.55maven:org.apache.tomcat.embed:tomcat-embed-core— patched in 11.0.22maven:org.apache.tomcat:tomcat— patched in 10.1.55maven:org.apache.tomcat:tomcat— patched in 11.0.22maven:org.apache.tomcat.embed:tomcat-embed-core— patched in 9.0.118maven:org.apache.tomcat:tomcat— patched in 9.0.118maven:org.apache.tomcat:tomcat-coyote— patched in 9.0.118maven:org.apache.tomcat:tomcat-coyote— patched in 10.1.55maven:org.apache.tomcat:tomcat-coyote— patched in 11.0.22
How to fix CVE-2026-41293
Fixed versions are recorded for 9 packages: maven:org.apache.tomcat.embed:tomcat-embed-core 10.1.55, maven:org.apache.tomcat.embed:tomcat-embed-core 11.0.22, maven:org.apache.tomcat:tomcat 10.1.55, maven:org.apache.tomcat:tomcat 11.0.22, maven:org.apache.tomcat.embed:tomcat-embed-core 9.0.118, maven:org.apache.tomcat:tomcat 9.0.118, maven:org.apache.tomcat:tomcat-coyote 9.0.118, maven:org.apache.tomcat:tomcat-coyote 10.1.55, maven:org.apache.tomcat:tomcat-coyote 11.0.22. No vendor patch reference has been recorded for CVE-2026-41293 in the tracked sources. Follow the references below for a fix, and treat the products listed above as exposed until the vendor states otherwise.
Threat activity tracking CVE-2026-41293
1 tracked threat in the Threadlinqs corpus references CVE-2026-41293, either in the campaign’s CVE list or as an indicator on the campaign record.
Sources
Enriched from CVE.org, FIRST EPSS, GitHub Security Advisories, public proof-of-concept repositories. Last verified by Threadlinqs on .